
Getting started
This guide assumes that you're familiar with DuneX operations and that your movie collection has
already been loaded into DuneX.
Please take note that DuneX does not "clean" its library whenever you add, remove or move items
within your folders structure.
In order to get the cleanest environment possible, please issue RELOAD and CLEAN commands for
each of your library paths in DuneX.

When everything is properly set up, you must shut DuneX down in order to commit changes to your
library and, finally, open DuneX2Mede8er.
The very first thing to do is opening the DuneX library file: do this by clicking on the toolbar item
pointed by the yellow arrow, or by choosing File-> Open.
Depending on whether you chose to load thumbnails or not, please allow some time for the process
to complete. On a 13" MacBook Pro, hardly a lightning fast machine, it takes 1 minute and 35
seconds to load a library of 801 items together with their thumbnails, against a time of 23 seconds to
load the same library without thumbnails!

Remember: if you get stuck, at any point during operations, you can check this guide accessing its
online version directly from the Help menu item.
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The toolbar
Let's take a look at what you got in the toolbar:

1. Open Library. Select and open the DuneX library file in XML format
2. Save XML. Click to have the application produce the relevant XML files for the selected

movie or for each of the movies in the selected folder. This funtion needs read/write access
to the file system where the item(s) is located.

3. mede8er. Builds and writes the mede8er.db database for the selected folder. The database
is required by Mede8er Jukebox and normally is built by the firmware with the "Scan folder"
function. This funtion needs read/write access to the file system where the item(s) is located.

4. TV Series XML. Produces all the files needed to enjoy the TV Jukebox offered by the latest
version of X2 series firmware; this funtion needs read/write access to the file system where
the item(s) is located.

5. Query Library. Brings up the query form window. See related pages for a full description of
this function.

6. Fix Movie Info. Clicking on this button starts a search on TMDB for the movie selected. If
any of the field in this panel is empty (showing "missing info") it will be filled with the data
retrieve on TheMovieDB. You can specify which language to uese in the setting panel (see
later on).

7. Update DuneX. This is available only if you use "Fix Movie Info"; the updated informations
will be written back to the DuneX library file and thus available both to DuneX and
DuneX2Mede8er form now on...

Most of these features are also available through the application menu, in the File and Tools
sections.
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The Library outline view
Once the library is loaded, you can easily browse it using the outline view on the left.

You can expand or collapse each node in the tree, by clicking on the small triangle at its left. You
can also expand or collapse ALL the root nodes by choosing View-> Expand all items or View->
Collapse all items.

Selecting a folder will show the Library Details panel, while selecting a single movie/TV episode will
show the relevant details panel (see following pages); the number of available functions depends on
which mode you've entered.
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The Library Details panel
If you select a folder, wether it being a root folder or a subfolder, you'll be be presented with scrolling
view of your movies' thumbnails and a recap of the status of the items within the folder. Thumbnails
are shown only if you chose to do so in the Preferences panel (default is NO).
Either way, hovering the mouse pointer above the folder thumbnails will show the movie title.

Take a look at the path field in the example: if it is written in red, it means that this particular folder
has not been mounted on your Mac and therefore it is not writable. A green colored path means that
everything is okay.

Exported items represents the number of movies, in the selected folder, already exported by DuneX.
Count is recursive and traverse all subfolders.
Recently Exported items gives you the count of those movies exported since the last time you ran
DuneX2Mede8er
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The Movie Details panel
This is what you get when selecting a single movie in the outline view on the left.
All the informations presented on the screen are read straight from DuneX library file.

The colour of the movie title reflects at a glance the file system status of the movie file: red means no
access while a green title represents the correct file system status (read/write access to the file).

Pay attention to the colored ball near the Export date (and in the outline view on the left):

• red: item has never been exported by DuneX, thus cannot be processed by
DuneX2Mede8er;

• yellow: item has already been exported before last run of DuneX2Mede8er and should not
receive any further attention; it is possibile to force processing of these items;

• green: item has been exported after your last run of DuneX2Mede8er and thus is fully
processable.

Tip: hovering the mouse pointer above the poster/cover of the movie will pop-up a tooltip with some
technical info about the movie.
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TV Series mode
This is what you get while clicking on a folder which DuneX identifies as "TV Show".
A little TV Icon helps you understand that you're dealing with a TV Series structure.
Exported items and Recently Exported items have the very same meaning fo the movie library view.

By using the button "TV Series XML", DuneX2Mede8er automatically produce the structure (XML
and JPG) required for the new TV Series Jukebox.

This function is still experimental, so use it with care!!! In any case nothing will be deleted or
modified, so your original files will be safe...

While you're here, take note of the path field: this time is green colored, because this path is actually
mounted on the computer where the screenshot was taken.
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TV Series - Episode details
Here you can see the episode detail view.
Only basic informations such as plot and title are shown, along with export date and status.
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Library Query *NEW*
Imagine you're dealing with a huge and complex library: tracking your movies, their position and their
status, it is not an easy task to accomplish.
Starting with version 1.4, DuneX2Mede8er offers you the chance to query your library and easily
manage the resulting items. You can search for:

• Genres (or categories), selecting from a drop down menu compiled using the categories
used by your movies and not some unuseful standard set

• Titles, cast and directors, using free text, case-insensitive, text searching with automatic
wildcard

• Duplicated IMDB Ids: get rid of those duplicated movies scattered all around your library
• Movies that need analysis by DuneX
• Movies with incomplete info (spot, actors, directors...) so you can use DuneX2Mede8er to fix

the missing info before writing your precious XML files
• Items that you exported from DuneX since the last time you ran DuneX2Mede8er: all your

new releases at a glance!
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Library Query - perform queries
Querying the library is simply a matter of choosing the query type, selecting parameter if required,
and clicking on the Query button.
The queries that need a parameter are listed on the left, while those on the right are ready to be
executed as is.

Once executed, the query produces its results in the form of a table whose columns are:

• Title
• Path
• Genres
• Cast

You will also find the count of the resulting items In the lower right corner of the table.

Selecting a row a clicking on Goto Outline will take you to the outline mode with the selected item
highlighted in movie details view. You can achieve the same result by double-clicking on a single
row.

Clicking on Reset will clear the result table and the parameter field; also the query selection will
reset to the default choice (by Genre).
The Close button will dispose of the query window, taking you back to the outline view without
affecting the currently selected item (movie or folder).
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Library Query - navigating the results
Once you've got back to outline view, either by clicking on the "Goto Outline" button or by double-
clicking on a selected item in the Query window, you can use the highlighted controls to cycle
through the items resulting from your query.
Each item will be highlighted in its position in the outline tree, automatically collapsing and expanding
nodes as required and updating the contents of the movie/TV episode details panel.

Those controls will track your position inside the result set and will remember the content of the
result set even you manually change focus in the outline tree; the controls will be cleared only if you
click on the Reset button in the query window.

While in outline view, you can freely select any other item, movie or folder, regardless of it being a
result item or not; you can go back to the whole result set by click on the Library Query button in the
toolbar or continue cycling through the set by using the arrow-shaped controls.
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Manage "watched" status
Version 1.3 adds a new menu item, under the File section, to easily toggle the watched indicator on
and off, for each individual movie.
This function works only at movie level and is therefore not available when an entire folder is
selected in outline view.

Warning: this function requires write access to the file system where the movie is located, as
managing the watched status implies writing or deleting a particular file.

Check "watched" status
You can always check wether a movie has been "watched" looking for the "eye" icon in the movie
details view, as you can see in the following example.

Warning: this function requires read-only (at least) access to the file system where the movie
is located, as managing the watched status implies reading a particular file.
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Refresh file system status*NEW*
You launch DuneX2Mede8er to update your library with some new release; so you load your 1000+
items library and start working, only to nootice that you forgot to mount the disks (local or network)
where your movies are. You're stuck, 'cause DuneX2Mede8er cannot do its job...
Since file system status is normally checked when loading the library, you're required to quit the
application, do the approriate mounting, launch once more DuneX2Mede8er and reload your library.
What a waste of time!

This pain it's over: simply use the new function in file menu called "Refresh FS status" after mounting
your disks (no need to quit the application), and DuneX2Mede8er will update its library reference so
you can perform your due maintenance.

You can always check if a folder/movie is accessible or not, by looking at the color of its title in the
detail panel: green is okay, red means "no way"!
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DuneX compatibility and automatic updates
Starting with version 1.3, DuneX2Mede8er is compatible with the soon-to-be-released version 0.9 of
DuneX; DuneX has undergone a lot of changes and I made every effort possibile to make
DuneX2Mede8er work with this new version while retaining backward compatibility with the current
stable version of DuneX.

Also version 1.3 introduces automatic updates through the use of the wonderful Sparkle framework
(http://sparkle.andymatuschak.org). DuneX2Mede8er checks his home website (www.myrtaart.com)
for an appcast XML which lists available updates along with a detailed changelog.
Checking is performed automatically if the relative setting is checked in the preferences panel, but
can also be forced using the following menu item...
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The Preferences panel
Here is a screenshot of the "Settings" panel:

1. Choose your preferred language for scraping with TheMovieDB
2. When checked, it creates automatically the mede8er.db whenever you perform the Save

XML action on a library folder.
3. When checked, it searches automatically on TMDB for updated movie infos in order to fill the

voids while writing the XML files for an entire folder
4. If checked it retrieves all the poster images while loading the library from file. This is not

recommended for large libraries as it has an impact on loading time and RAM usage.
5. If checked, DuneX2Mede8er will check once in a day for updates; it needs an Internet

connection to www.myrtaart.com
6. DuneX2Mede8er save the date when it was last used. This information is used to identify (by

color) the status of each movie. You can reset the last run date back to January, 1st 1970 by
clicking on the button Reset.
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